[Main Page]

Installing Angular web client

_.-~= Installing Angular web client
Wed Apr 29 16:34:35 EDT 2020
Running npm install:

> core-js@3.2.1 postinstall /home/test/Evergreen/Open-ILS/src/eg2/node_modules/@angular-devkit/build-angular/node_modules/core-js
> node scripts/postinstall || echo "ignore"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)


> core-js@2.6.10 postinstall /home/test/Evergreen/Open-ILS/src/eg2/node_modules/babel-runtime/node_modules/core-js
> node postinstall || echo "ignore"


> @angular/cli@8.3.12 postinstall /home/test/Evergreen/Open-ILS/src/eg2/node_modules/@angular/cli
> node ./bin/postinstall/script.js


> core-js@3.3.2 postinstall /home/test/Evergreen/Open-ILS/src/eg2/node_modules/core-js
> node postinstall || echo "ignore"

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/webpack-dev-server/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/@angular/compiler-cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

added 1200 packages from 1118 contributors and audited 16619 packages in 109.387s
found 466 vulnerabilities (451 low, 4 moderate, 11 high)
  run `npm audit fix` to fix them, or `npm audit` for details
Return Value = 0
Running ng build --prod:
Your global Angular CLI version (8.3.26) is greater than your local
version (8.3.12). The local Angular CLI version is used.

To disable this warning use "ng config -g cli.warnings.versionMismatch false".

chunk {0} 0.a9c3396448263a282b8c.js () 29.8 kB  [rendered]
chunk {1} 1.9618c0d5118cfccc5e60.js () 450 kB  [rendered]
chunk {2} 2.a82ec910a4a2c3620ecd.js () 14.5 kB  [rendered]
chunk {3} common.fa6f7dc7398a9bfe8cc7.js (common) 18.4 kB  [rendered]
chunk {4} 4.a519336dc3688f059841.js () 66.3 kB  [rendered]
chunk {5} 5.291238da3b42df2dd458.js () 164 kB  [rendered]
chunk {6} 6.33ad017dc45e5a101cf8.js () 19.4 kB  [rendered]
chunk {7} runtime.a4c078a82bbc61f9212a.js (runtime) 2.98 kB [entry] [rendered]
chunk {8} 8.465709ee1f49683fa99d.js () 118 kB  [rendered]
chunk {9} 9.6902d868a42eab621505.js () 17.2 kB  [rendered]
chunk {10} 10.f9583acceb87c49be546.js () 13.5 kB  [rendered]
chunk {11} main.0c33ec8e758f4bd08709.js (main) 462 kB [initial] [rendered]
chunk {12} polyfills.f44815c8d3b2342634c0.js (polyfills) 35.9 kB [initial] [rendered]
chunk {13} styles.6ef20b9c87f1ad20d4c5.css (styles) 140 kB [initial] [rendered]
chunk {14} 14.cfd750090cf66f2e2709.js () 26.6 kB  [rendered]
chunk {15} 15.7c57a0a8ca098bc5a562.js () 32.1 kB  [rendered]
chunk {16} 16.429ceb47a79b5120bc18.js () 113 kB  [rendered]
chunk {17} 17.7ccf57469457e99aa036.js () 43.2 kB  [rendered]
chunk {18} 18.339a7cf9419e1d71ce52.js () 537 kB  [rendered]
chunk {19} 19.ee236018e956cc5a0e0b.js () 30.2 kB  [rendered]
chunk {20} 20.bed98fdd14668954a842.js () 130 kB  [rendered]
chunk {21} 21.6391ac3675e7db40bfc4.js () 15.2 kB  [rendered]
chunk {22} 22.cbf7ba500693ce88a35d.js () 9.34 kB  [rendered]
chunk {23} 23.e7dee06144ef0fd7bbc2.js () 89.4 kB  [rendered]
chunk {24} 24.97c7063505513c69f532.js () 13.2 kB  [rendered]
chunk {25} 25.9df73768a4cf03e718bd.js () 9.42 kB  [rendered]
chunk {26} 26.991b6291073af1a01232.js () 8.02 kB  [rendered]
chunk {27} 27.e1bb00890d436d57d949.js () 180 kB  [rendered]
chunk {28} 28.578e481d1447c99a90dd.js () 891 bytes  [rendered]
chunk {29} 29.59efb744723f345b7be2.js () 539 bytes  [rendered]
chunk {30} 30.fd751f5bc081088ba956.js () 590 bytes  [rendered]
chunk {31} 31.fe39a42c8a24bdf840df.js () 514 bytes  [rendered]
chunk {32} 32.972e0724ca081cc3de11.js () 507 bytes  [rendered]
chunk {33} 33.687f8c159aa840e191ba.js () 56.7 kB  [rendered]
chunk {scripts} scripts.031ba5aefb0caf9b26f9.js (scripts) 19.3 kB [entry] [rendered]
Date: 2020-04-29T20:39:40.019Z - Hash: 9e9d2fb5e2d82f6fb803 - Time: 187770ms
Return Value = 0
Running npm run test:

> eg@0.0.0 test /home/test/Evergreen/Open-ILS/src/eg2
> npm run create-mock-idl; ng test


> eg@0.0.0 create-mock-idl /home/test/Evergreen/Open-ILS/src/eg2
> cd src/test_data && perl idl2js.pl

Browserslist: caniuse-lite is outdated. Please run next command `npm update`
29 04 2020 16:39:59.412:INFO [karma-server]: Karma v4.4.1 server started at http://0.0.0.0:9876/
29 04 2020 16:39:59.415:INFO [launcher]: Launching browsers ChromeHeadless, FirefoxHeadless with concurrency unlimited
29 04 2020 16:39:59.428:INFO [launcher]: Starting browser ChromeHeadless
29 04 2020 16:39:59.637:INFO [launcher]: Starting browser Firefox

ERROR in app/core/format.spec.ts:45:22 - error TS2554: Expected 4 arguments, but got 3.

45         orgService = new OrgService(netService, authService, pcrudService);
                        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  app/core/org.service.ts:39:9
    39         private pcrud: PcrudService
               ~~~~~~~~~~~~~~~~~~~~~~~~~~~
    An argument for 'pcrud' was not provided.
app/core/org.spec.ts:28:22 - error TS2554: Expected 4 arguments, but got 3.

28         orgService = new OrgService(netService, authService, pcrudService);
                        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  app/core/org.service.ts:39:9
    39         private pcrud: PcrudService
               ~~~~~~~~~~~~~~~~~~~~~~~~~~~
    An argument for 'pcrud' was not provided.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! eg@0.0.0 test: `npm run create-mock-idl; ng test`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the eg@0.0.0 test script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/test/.npm/_logs/2020-04-29T20_40_04_023Z-debug.log
Return Value = 1
Return Value = 0
End of Installing AngularJS web client =~-._